يمكن أن يمنع Android 14 المستخدمين من التحميل الجانبي للتطبيقات القديمة

يمكن أن يحد التغيير من انتشار البرامج الضارة على النظام الأساسي

يقال إن Google تعمل على تغيير جديد يتم تعيينه على الهواء مباشرة والذي سيمنع المستخدمين من تثبيت التطبيقات القديمة على أجهزتهم. تفرض الشركة بالفعل الحد الأدنى من متطلبات مستوى واجهة برمجة التطبيقات للتطبيقات على متجر Play ، مما يمنع المطورين من نشر التطبيقات التي تستهدف إصدارات Android القديمة. ومع ذلك ، لا يمنع هذا التقييد المستخدمين من التحميل الجانبي للتطبيقات القديمة.

تهدف Google إلى معالجة ذلك باستخدام Android 14 ، ويشير تغيير الرمز المنشور حديثًا (عبر 9to5Google) إلى أن الشركة ستفرض متطلبات API أكثر صرامة مع الإصدار القادم. بمجرد دخول التغيير حيز التنفيذ ، لن يتمكن المستخدمون بعد الآن من تحميل ملفات APK للتطبيقات التي لا تلبي مستوى API المحدد. سيمنع أيضًا متاجر تطبيقات الجهات الخارجية من تثبيت التطبيقات التي لا تلبي الإرشادات الجديدة.

في البداية ، يقال إن Android 14 سيحظر التطبيقات التي تستهدف بشكل خاص إصدارات Android القديمة. ومع ذلك ، تخطط Google لزيادة الحد الأدنى إلى Android 6.0 Marshmallow بمرور الوقت وتنفيذ آلية ” [it] حتى “. 9to5Google يشير إلى أن الشركة على الأرجح ستمنح مصنعي المعدات الأصلية خيار تمكين أو تعطيل الميزة وتعيين حد للتطبيقات القديمة لأجهزتهم.

تهدف هذه الخطوة إلى الحد من انتشار البرامج الضارة ، حيث “يمكن أن تستهدف البرامج الضارة إصدارات SDK القديمة لتجنب فرض سلوك واجهة برمجة التطبيقات الجديدة” ، كما يشير المطور المسؤول عن التغيير. سيظل لدى المستخدمين خيار تثبيت التطبيقات القديمة على أجهزتهم من خلال غلاف أوامر باستخدام علامة جديدة ، لكن العملية لن تكون بسيطة مثل التحميل الجانبي لملف APK. من خلال جعل العملية أكثر تعقيدًا ، ستقلل Google من احتمال قيام المستخدمين بتثبيت تطبيق محمّل بالبرامج الضارة على أجهزتهم عن غير قصد.

نتوقع معرفة المزيد حول هذا التغيير في الأسابيع المقبلة عندما تطلق Google أول إصدار لمعاينة المطورين لنظام Android 14. تابع تغطيتنا لمعرفة كل شيء عن التغييرات في ترقية النظام الأساسي الرئيسية التالية.

مصدر:

عبر:

التعليقات

اترك تعليقاً

لن يتم نشر عنوان بريدك الإلكتروني. الحقول الإلزامية مشار إليها بـ *